Live branding

Wanneer je een live tile toevoegd kies je een template voor de live tile. Hierbij kan je zelf kiezen voor 45 verschillende templates. Vervolgens is op de live tile vaak een plaatje en tekst zichtbaar en ook het Small logo dat je met je applicatie meeleverd zoals hier in webradio

 

Via the TileUpdateManager kan je eenvoudig een de XML voor een dergelijke live tile verkrijgen en dan voorzien van je eigen data. Zo stukje XML kan er zo uitzien:

<tile><visual>
                                        <binding template=""TileSquareText02""><text id=""1"">{0}</text><text id=""2"">{1}</text></binding>
                                        <binding  template=""TileWideText01""><text id=""1"">{0}</text><text id=""2"">{1}</text><text id=""3""></text><text id=""4""></text><text id=""5""></text></binding>
                                   </visual></tile>
 

Wist je dat het echt ook mogelijk is om het small logo te verstoppen en de naam van de applicatie te tonen. Dit kan heel eenvoudig de het attribute "branding" toe te voegen op het binding element in de XML. De waarde moet dat zijn name. Dan zou het er zo uitzien:

<tile><visual>
                                        <binding branding='name' template=""TileSquareText02""><text id=""1"">{0}</text><text id=""2"">{1}</text></binding>
                                        <binding branding='name'  template=""TileWideText01""><text id=""1"">{0}</text><text id=""2"">{1}</text><text id=""3""></text><text id=""4""></text><text id=""5""></text></binding>
                                   </visual></tile>
 

Wanneer je helemaal niks wil laten zien (dus geen logo en geen naam) zet je branding op 'none' 

  •   @tfsbuck thanks
  •   @densto @VSTS see email. one just timed out but that causing the other one that was waiting got picked up directly
  •   @VSTS did you send all your build agents already for weekend?
  •   @tfsbuck already made a issue https://t.co/u0EcaMewlV
  •   @tfsbuck back again :) you guys updated tf-cli today from .11 to .13 and now getting this error when try to publish… https://t.co/GLMVwL7HDZ
  •   @jpaternotte Soort zoekt soort! Past goed tussen de andere 149 clowns
  •   @sandeepchads @VSTS in the vsts sdk they are already visible; just returning 401
  •   RT @msbotframework: LUIS and the Azure Bot Service have just hit GA! 🎉 https://t.co/QVttVKrSWe
  •   @sandeepchads @VSTS Integration with my activity feed. Are the apis already open?
  •   @tfsbuck nice i had hard time to find the reproduction path. they also fixed my issue with publishing extension. new build task coming soon!